Glowforge App Service Degradation
Incident Report for Glowforge
Resolved
This incident has been resolved.
Posted May 06, 2022 - 07:46 PDT
Monitoring
Service performance has recovered and we are monitoring it for any further issues.
Posted May 06, 2022 - 07:20 PDT
Investigating
An issue with an upstream service is causing slow response times for many operations on app.glowforge.com. Our engineering team is investigating into possible mitigations.
Posted May 06, 2022 - 06:38 PDT
This incident affected: The Glowforge App (app.glowforge.com) (The Glowforge App (app.glowforge.com)) and Google Cloud (Google Cloud SQL, Google Cloud Storage).