Glowforge app incident 6:08pm to 6:20pm PDT
Incident Report for Glowforge
Resolved
This incident has been resolved.
Posted Jun 02, 2020 - 19:00 PDT
Investigating
Between 6:08 pm and 6:20pm PDT, an incident affecting the Glowforge app was causing an elevated number of prints to fail to start. This incident has now been resolved.
Posted Jun 02, 2020 - 19:00 PDT
This incident affected: The Glowforge App (app.glowforge.com) (The Glowforge App (app.glowforge.com)) and Glowforge Services (Glowforge Print Service).