Glowforge app freezing when loading designs
Incident Report for Glowforge
Resolved
This incident has been resolved.
Posted Feb 13, 2024 - 07:06 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 13, 2024 - 01:21 PST
Investigating
We're investigating an issue that may cause a the app to freeze on a screen that says "Rendering Your Design"
Posted Feb 12, 2024 - 23:09 PST
This incident affected: The Glowforge App (app.glowforge.com) (The Glowforge App (app.glowforge.com)).