Degraded performance
Incident Report for Glowforge
Resolved
This incident has been resolved.
Posted Sep 28, 2020 - 14:00 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 28, 2020 - 12:07 PDT
Investigating
The team has identified an issue impacting performance of Glowforge Print services. Some users may encounter slower than usual performance when uploading, preparing prints, calibrating and refreshing lid images. The team is currently working on a fix for the issue.
Posted Sep 28, 2020 - 10:50 PDT
This incident affected: The Glowforge App (app.glowforge.com) (The Glowforge App (app.glowforge.com)) and Glowforge Services (Glowforge Print Service).