Glowforge home page is not loading
Incident Report for Glowforge
Resolved
This incident has been resolved.
Posted Nov 11, 2022 - 00:02 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 11, 2022 - 00:01 PST
Investigating
The Glowforge home page is currently resulting in a 404 due to issues with a third-party vendor. We are currently investigating possible solutions. The Glowforge app and printers are unaffected.
Posted Nov 10, 2022 - 23:15 PST