Glowforge Checkout Outage
Incident Report for Glowforge
Resolved
This incident has been resolved.
Posted Jul 05, 2022 - 14:45 PDT
Monitoring
Shopify is currently recovering and we are monitoring it for any further issues.
Posted Jul 05, 2022 - 14:15 PDT
Investigating
An issue with Shopify may cause trouble for customers who attempt to build carts and/or check out at glowforge.com and shop.glowforge.com.
Posted Jul 05, 2022 - 13:27 PDT
This incident affected: The Glowforge Shop (shop.glowforge.com).