Magic Canvas Service Degradation
Incident Report for Glowforge
Resolved
This incident has been resolved.
Posted Dec 03, 2024 - 17:51 PST
Investigating
We have identified an issue causing degraded service that is impacting Magic Canvas. This issue is being investigated now.
Posted Dec 03, 2024 - 17:31 PST
This incident affected: The Glowforge App (app.glowforge.com) (The Glowforge App (app.glowforge.com)).