partial glowforge.com performance issues
Incident Report for Glowforge
Resolved
The third party service and glowforge.com's product page has recovered for the affected users since 20:42 PDT
Posted Sep 06, 2021 - 21:01 PDT
Investigating
We're investigating an issue with a third-party service taking longer to respond, causing some glowforge.com users to wait longer for pages to load. We'll update this when it's resolved.
Posted Sep 06, 2021 - 18:00 PDT
This incident affected: The Glowforge Homepage (glowforge.com) (Yotpo Status Yotpo Widgets, Batch requests, JS & CSS).