Glowforge App Performance Google Cloud Services

Incident Report for Glowforge

Resolved

This issue has been resolved by Google Cloud, and the Glowforge app is now operating normally. Our team will continue to monitor Google Cloud services closely to ensure no further impacts.
Posted Jun 12, 2025 - 16:57 PDT

Investigating

Our team is currently investigating an issue that is stemming from a Google cloud service interruption. This is impacting the Glowforge app.
Posted Jun 12, 2025 - 11:15 PDT
This incident affected: The Glowforge App (app.glowforge.com) (The Glowforge App (app.glowforge.com)).