In-app Chat Outage

Incident Report for Glowforge

Resolved

In app chat has been restored.
Posted Dec 18, 2025 - 10:28 PST

Investigating

Outage with 3rd party in-app chat provider. Please proceed directly to the chat in the meantime.

https://glowforge.com/b/community-chat

Designing and printing are unaffected.
Posted Dec 17, 2025 - 15:15 PST