Glowforge App Performance Google Cloud Services
Incident Report for Glowforge
Resolved
This incident has been resolved.
Posted Jan 08, 2025 - 10:32 PST
Monitoring
This issue has been resolved by Google Cloud, and the Glowforge app is now operating normally. Our team will continue to monitor Google Cloud services closely to ensure no further impacts
Posted Jan 08, 2025 - 09:19 PST
Investigating
Our team is currently investigating an issue that is stemming from a Google cloud service interruption. This is impacting the Glowforge app responsiveness when trying to complete prints.
Posted Jan 08, 2025 - 08:27 PST
This incident affected: Google Cloud (Google Cloud Storage).