Glowforge App outage 11/8/19 1:55pm - 1:59pm PST
Incident Report for Glowforge
Resolved
As of 1:59pm PST, we have resolved the outage on app.glowforge.com.
Posted Nov 08, 2019 - 14:06 PST
Investigating
We are currently investigating an issue affecting app.glowforge.com. A "The website is under heavy load" or "We're sorry, an unexpected error has occurred" message may appear when trying to access the Glowforge app.
Posted Nov 08, 2019 - 14:02 PST
This incident affected: The Glowforge App (app.glowforge.com) (The Glowforge App (app.glowforge.com)).