Errors while Printing

Incident Report for Glowforge

Resolved

The incident has been resolved.
Posted Dec 15, 2025 - 13:58 PST

Monitoring

A fix has been implemented and we are monitoring the results
Posted Dec 15, 2025 - 13:09 PST

Investigating

We're investigating an issue that may interfere with printing. We'll update this when it's resolved.
Posted Dec 15, 2025 - 12:52 PST