Possible Glowforge App service degradation

Incident Report for Glowforge

Resolved

This incident has been resolved.
Posted Dec 05, 2023 - 09:50 PST

Monitoring

Our systems are currently undergoing recovery. Continual monitoring is in place to confirm complete resolution.
Posted Dec 05, 2023 - 09:10 PST

Investigating

We are currently investigating a possible degradation with Glowforge services. Update to come.
Posted Dec 05, 2023 - 09:00 PST