Glowforge workspace service degradation

Incident Report for Glowforge

Resolved

This incident has been resolved. Users who were experiencing this issue may need to clear their browser's cache before trying again.
Posted May 22, 2023 - 09:34 PDT

Investigating

The team is currently investigating an issue impacting design workspace in the Glowforge App. After selecting a material, the workspace may appear blank or white.
Posted May 22, 2023 - 08:23 PDT
This incident affected: The Glowforge App (app.glowforge.com) (The Glowforge App (app.glowforge.com)).