Glowforge App service degradation
Incident Report for Glowforge
Resolved
This incident has been resolved. Users who were experiencing this issue may need to refresh their browser window before trying again.
Posted May 04, 2022 - 08:38 PDT
Investigating
We're investigating an issue that may interfere with using the Glowforge App starting on May 4, 2022 at 6:45am PST. We'll update this when it's resolved.
Posted May 04, 2022 - 08:11 PDT
This incident affected: The Glowforge App (app.glowforge.com) (The Glowforge App (app.glowforge.com)).