Glowforge App service degradation 11/14/2019 3:28pm - 3:34pm PST
Incident Report for Glowforge
Resolved
As of 3:34pm PST, we have resolved an issue that caused degraded service when using the Glowforge App to view the Design Library, plan prints, and calibrate.
Posted Nov 14, 2019 - 15:38 PST
Investigating
We are currently investigating an issue causing degraded service when using the Glowforge App
Posted Nov 14, 2019 - 15:32 PST
This incident affected: The Glowforge App (app.glowforge.com) (The Glowforge App (app.glowforge.com)).