Glowforge Shop Issues

Incident Report for Glowforge

Resolved

This incident has been closed.
Posted Aug 07, 2025 - 16:07 PDT

Update

This incident has been resolved.
Posted Aug 07, 2025 - 16:05 PDT

Update

Shopify is currently recovering and we are monitoring it for any further issues.
Posted Aug 07, 2025 - 16:03 PDT

Investigating

An issue with Shopify may cause trouble for customers who attempt to access shop.glowforge.com
Posted Aug 07, 2025 - 15:25 PDT
This incident affected: The Glowforge Shop (shop.glowforge.com).