South America - Glowforge.com app impairment 9:45am PDT 6/13/2019
Incident Report for Glowforge
Resolved
This issue has been resolved as of 1:00am PDT 6/13/2019
Posted Jun 13, 2019 - 10:12 PDT
Investigating
Some customers in Brazil and greater South America may be having trouble logging in and using the app. The team is currently investigating.
Posted Jun 13, 2019 - 09:50 PDT
This incident affected: The Glowforge Homepage (glowforge.com), The Glowforge App (app.glowforge.com), and The Glowforge Shop (shop.glowforge.com).