Glowforge App Performance

Incident Report for Glowforge

Resolved

This incident has been resolved.
Posted May 20, 2025 - 09:30 PDT

Investigating

We're investigating an issue that may cause a slowdown when using app.glowforge.com. We'll update this when it's resolved.
Posted May 20, 2025 - 08:51 PDT
This incident affected: The Glowforge App (app.glowforge.com) (The Glowforge App (app.glowforge.com)).