Glowforge App Performance

Incident Report for Glowforge

Resolved

This incident has been resolved.
Posted May 27, 2025 - 11:22 PDT

Monitoring

We are seeing recovery from the issue and are monitoring.
Posted May 27, 2025 - 10:03 PDT

Investigating

We are investigating an issue that is causing an error message on app.glowforge.com. We will update when it’s resolved.
Posted May 27, 2025 - 07:04 PDT
This incident affected: The Glowforge App (app.glowforge.com) (The Glowforge App (app.glowforge.com)).