Telephone Availability
Incident Report for Glowforge
Resolved
Our telephony provider has resolved the outage impacting our inbound and outbound phones. The Glowforge Customer Care team is available again by all supported channels at support.glowforge.com
Posted Apr 22, 2024 - 08:54 PDT
Investigating
We are investigating an outage with our telephony provider. This is impacting our ability to make and receive calls with the Glowforge Community. We apologize for the inconvenience! Your call is important to us. We will have things back up and running as quickly as possible. Please check back here for updates. Our team is still available via web form at support.glowforge.com
Posted Apr 22, 2024 - 08:22 PDT